295 Views
2018 Jun 06Trainingtechnology
img

در این مقاله نحوه راه اندازی و استفاده از IPIP Tunnel را بین دو روتر میکروتیک توضیح می دهم.

این روش زمانی که بخواهیم بین دو شبکه (Lan) که از طریق Gateway خود به شبکه اینترنت یا اینترانت متصل هستند را به یکدیگر متصل کنیم و از امکاناتی که در دو شبکه قرار دارد استفاده کنیم، مثلاً فایل سرور موجود در شبکه دوم رو از شبکه اول ببینیم و همینطور از امکانات موجود دیگه ( Active directory , Print Server , VOIP, … ) استفاده کنیم کاربرد دارد.
در این روش بصورت مجازی روتر هایی که در مسیر قرار دارند را حذف می کنیم و دو شبکه از طریق روتر های خود بصورت مستقیم با هم در ارتباط خواهند بود.

ایجاد تانل Tunneling:
فرض میکنیم روتر شماره یک با مشخصات زیر موجود هست:
Public IP : 85.15.1.10
LAN IP range : 192.168.200.1/24
و روتر دوم ما با این مشخصات هست:
Public IP : 5.16.14.22
Lan IP address : 192.168.220.1/24
حالا یک ارتباط تانل نیاز داریم به این شکل:
در روتر اول این کانفیگ رو می نویسیم:
/interface ipip add disabled=no dscp=0 local-address=85.15.1.10 mtu=1480 name=ipip1-GEEKBOY.IR remote-address=5.16.14.22

/ip address add address=10.0.0.1/30 interface=ipip1-GEEKBOY.IR

/ip route add dst-address=192.168.220.0/24 gateway=10.0.0.2

در خط اول ما تانل رو به سمت روتر دوم ایجاد می کنیم در خط دوم یک IP به همین تانلی که زدیم سمت خودمون میدیم تا بتونیم روش روتینگ ایجاد کنیم، در سوم هم روتی که گفتیم را می نویسیم تا مشخص بشه اون رنج IP (شبکه داخلی روتر دوم) را باید از چه طریق بهش برسیم.
در روتر دوم هم دقیقاً همین تنظیمات رو اعمال میکنیم و فقط یه سری تغییرات کوچک مثل IP ها و روت ها رو تغییر میدیم:
/interface ipip add disabled=no dscp=0 local-address=5.16.14.22 mtu=1480 name=ipip1-GEEKBOY.IR remote-address=85.15.1.10
/ip address add address=10.0.0.2/30 interface=ipip1-GEEKBOY.IR
/ip route add dst-address=192.168.200.0/24 gateway=10.0.0.1
به این ترتیب تانل IP ایجاد شده و بین دو شبکه بصورت مجازی ارتباط بر قرار می شود.

IPIP Tunnel

Mikrotik

آموزش شبکه

آموزش میکروتیک

میکروتیک

راه اندازی تانل ipip